Montag, 26. August 2019

iTV PlayGo



und wieder einem Kind ein Spielzeug vorenthalten..

ein Modellbild:



Aus dem Spielzeugfernseher, der mit einem Aufziehwerk zwei Papierwalzen drehte und dabei eine lustige Melodie klimperte, ist ein echtes Internetfernsehen geworden. So ein fertiges Gehäuse für eigene Zwecke umzubauen erfordert oft mehr Arbeit als eine Neukonstruktion.

Den Anfang machte der Displayrahmen, der auch den raspberry hält


es folgte eine Vorrichtung um den Drehencoder mit dem vorhandenen roten Knopf drehen zu können. Das hier war der erste Versuch. Der hatte zwar funktioniert aber hat zu tief gebaut um die Rückwand noch drauf zu bekommen.


die Ratschkupplung für den roten Knopf wurde fixiert, die Öffnung aufgebohrt und ein Adapter für die abgeflachte Achse des encoders eingeklebt.


An der Rückwand dremelte ich diverse Halterungen ab und brachte an genau ausgeklügelter Stelle die Öffnung für den Lautsprecher an.


es stellte sich heraus das der Lautsprecher stark klirrte. Ersatz hatte ich grad nicht, also baute ich mir welchen


hier ist alles soweit eingebaut

hier zeige ich die Lötpunkte am raspberry. Links oben in der Nähe der USB-Buchse greife ich die 5V für den LM386-NF-Verstärker ab. Die NF wird an der Klinkenbuchse abgenommen und die beiden Kanäle über die Widerstände zusammengeführt. Links unten das gelbe Kabel versorgt den encoder mit 3,3V.


Um den Verstärker in die Rundung anzupassen knipste ich die beiden vorderen Ecken der Platine ab und versah das Poti mit einer zusätzlichen Überwurfmutter auf der Innenseite des Gehäuses.



Das USB-Kabel zur Spannungsversorgung lies ich nach oben hinter dem Tragegriff abgehen.

Das Fensehen in Funktion:






das iTV hatte mich weiterhin beschäftigt. Hier ein Zwischenstand:


aber es ging weiter. Mich störte ein Knarzen und Zwitschern im Lautsprecher, so ähnlich als wenn man ein Handy neben ein Radio legt. Ich ersetzte NF-Leitung und sogar Stromversorgungskabel durch abgeschirmte Leitungen, baute mit dem Blech eines ZF-Filters ein Abschirmkästchen um den NF-Verstärker. Testete andere Stromversorgungen. Aber keine Chance. Ich konnte die Geräusche nicht beeinflussen. Sie waren auch mit abgezogenem Display vorhanden sowie mit deaktiviertem GPIOD. Ich stellte allerdings fest, daß im offline-Betrieb keine Geräusche zu hören waren. Wohl aber beim Fernsehempfang, als auch beim Hochfahren des Raspberry. Einen weiteren Zusammenhang stellte ich fest, und zwar je kräftiger der WLAN-Empfang war, desto leiser wurden die Geräusche. Und es gab noch eine Abhängigkeit. Das war die Lage des Verstärkers im Gehäuse. An einer Stelle am unteren Rand war kaum noch was zu hören. Hier setzte ich dann an und befestigte eine kleine Endstufe an dieser Stelle. Das Poti wanderte dann von der Seite in die bereits vorhandene Bohrung an der Rückwand. Jetzt war endlich Stille. Nur bei schlechtem WLAN-Empfang ist noch leise was zu hören.

Wie zu sehen ist ersetze ich im Lauf der Fehlersuche den 2er Raspberry durch einen 3A+. Das gab zumindest mal einen Leistungsschub. Ob internes oder externes WLAN hatte keinen Einfluß auf die Einstrahlungen in den Verstärker.


Keine Kommentare:

Kommentar posten